Home Forums Chart Support Culture issue

Culture issue

Viewing 4 posts - 1 through 4 (of 4 total)
  • #30279


    my chart don´t fetch the correct culture . Is that the correct format?

    // set culture
    decimalSeparator: “,”,
    digitGroupSeparator: “.”,
    days: [“Montag”, “Dienstag”, “Mittwoch”, “Donnerstag”, “Freitag”, “Samstag”, “Sonntag”],
    month: [“Januar”, “Februar”, “März”, “April”, “Mai”, “Juni”, “Juli”, “August”, “September”, “Oktober”, “November”, “Dezember”],
    var chartServiceEventsByMonth = new CanvasJS.Chart(“ServiceEventsByMonth”, {
    culture: “de”,



    You seem to have setting culture parameter wrongly. Passing months as months: [“Januar”, “Februar”, “März”, “April”, “Mai”, “Juni”, “Juli”, “August”, “September”, “Oktober”, “November”, “Dezember”] should work fine in your case. Please refer documentation for options available in culture.

    If you are still facing issue, kindly create JSFiddle reproducing the issue you are facing and share it with us so that we can look into the chart options being used, understand the scenario better and help you resolve.

    From what we have observed, sometimes things get delayed mostly when we are not able to reproduce the issue or not able to understand the exact requirements or the solution that we provide may not work properly due to the variation in chart-options being used by you and us.

    Having a JSFiddle helps us in figuring out the issue and many a time we can just edit your code on JSFiddle to fix the issue right away.

    Vishwas R
    Team CanvasJS


    @Vishwas R
    Thanks, but is still not working see here https://jsfiddle.net/a1m9sodL/



    As you are using formatDate method, you should pass culture within the parameters of the method – defaults to “en”. Also for showing customize short-months within labels, you should be passing shortMonths within culture parameters, please refer documentation for more information. Please take a look at this updated JSFiddle.

    Vishwas R
    Team CanvasJS

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.