Home forums Using CanvasJS Tooltip is not working correctly

This topic contains 2 replies, has 2 voices, and was last updated by  Suyash Singh 1 week ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #17270

    sumit1191
    Member

    [
    { label: ‘ Actual’, data: {{rbjc.GraphTotalRevenue}} },
    { label: ‘ Goal’, data: {{rbjc.GraphTotalRevenueGoal}} },

    ],
    {
    bars: { show: true, fill: true, lineWidth: 1, order: 1, fillColor: { colors: [{ opacity: 0.5 }, { opacity: 0.9}] } },
    colors: [‘{{rbjc.color.actual}}’, ‘{{rbjc.color.goal}}’],
    series: { shadowSize: 1 },
    xaxis:{ font: { color: ‘#000’ }, position: ‘bottom’, ticks: {{rbjc.GraphTicks}}, tickOptions: { angle: 30 } },
    yaxis:{ font: { color: ‘#333’ }, min: 0 },
    grid: { hoverable: true, clickable: true, borderWidth: 0, color: ‘#ccc’ },
    tooltip: true

    }

    #17271

    sumit1191
    Member

    The Whole UI Code…
    <div ui-jq=”plot” data-ng-if=”rbjc.showGraph” ui-options=”
    [
    { label: ‘ Actual’, data: {{rbjc.GraphTotalRevenue}} },
    { label: ‘ Goal’, data: {{rbjc.GraphTotalRevenueGoal}} },
    ],
    {
    bars: { show: true, fill: true, lineWidth: 1, order: 1, fillColor: { colors: [{ opacity: 0.5 }, { opacity: 0.9}] } },
    colors: [‘{{rbjc.color.actual}}’, ‘{{rbjc.color.goal}}’],
    series: { shadowSize: 1 },
    xaxis:{ font: { color: ‘#000’ }, position: ‘bottom’, ticks: {{rbjc.GraphTicks}}, tickOptions: { angle: 30 } },
    yaxis:{ font: { color: ‘#333’ }, min: 0 },
    grid: { hoverable: true, clickable: true, borderWidth: 0, color: ‘#ccc’ },
    tooltip: true,
    }

    data-ui-refresh=”rbjc.GraphTotalRevenue” style=”height: 400px”>
    </div>

    #17274

    Suyash Singh
    Moderator

    @sumit1191,

    The chart options you are using doesn’t seem to be in the format required by CanvasJS. Please refer this page to know more about the chart options accepted by CanvasJS.
    ___
    Suyash Singh
    Team CanvasJS

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.