Home forums Using CanvasJS "Superimposed" Bar chart

Tagged: 

This topic contains 9 replies, has 3 voices, and was last updated by  guilhermemaranhao 4 months, 3 weeks ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #23720

    Hi there,

    Is there a specific chart or option that I am able to do something like that (image below)?

    Superimposed graph

    Actually, it’s not a multi series bar chart, but a “superimposed graph”.

    Thank you

    #23721

    the image didn’t load.

    The link is: superimposed chart

    #23722

    Or, is it possible to set fillOpacity to a single dataPoint?

    I did it just for the whole data set.

    #23724

    @guilhermemaranhao,

    You can achieve this by combining column chart with error chart as shown in this JSFiddle.


    Vishwas R
    Team CanvasJS

    #23727

    Thank you, Vishwas.

    I’ll take a look!

    #23730

    Great, Vishwas! That’s exactly what I need!

    I’m facing another issue related to the labels visibility. It seems to be very silly, but I didn’t find a solution.
    Some of my labels aren’t being shown, their visibility is interleaved, i.e.: it shows the first, third, fifth, and so on…
    Does it have to do with the quantity of labels? There are 27! is it possible do show all of them?
    Do I need to set something? Or

    Thank you,

    Guilherme

    #23750

    Guilherme,

    Axis labels will be shown at every interval – which is auto-calculated based on parameters like axis minimum, axis maximum, etc. You can change interval to show all labels. In case of date-time axis, set intervalType along with interval according to your requirements.

    If you are still facing any issue, kindly create JSFiddle reproducing the issue you are facing and share it with us so that we can look into your code, understand the use-case better and help you out.


    Vishwas R
    Team CanvasJS

    #23853

    Thank you, Vishwas.

    This JSFiddle shows my issue. I’d like to have all my labels shown, but it seems it’s shown according to the screen size, even if I set

    axisX:{
            minimun: 28
          }

    which I supposed is not for that purpose, as long I’m using label instead of X points.

    Is there a way to ignore the screen size and always show all the labels?

    Regards and Happy Christmas!

    Guilherme

    #23861

    @guilhermemaranhao,

    You can achieve the above requirement by setting the interval of Axis X to 1. Please take a look at this updated jsfiddle.

    ___
    Shashi Ranjan
    Team CanvasJS

    #23863

    Thank you, @shashiranjan!

    Solved!

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.