Home forums Using CanvasJS Graph backgrounds VS StripLines layer order?

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29537

    I would like to have a chart with:
    1) A general background color
    2) Another background color just for the “graph part”
    3) Several axisX StripLine displayed on top of the “graph part background”

    There’s the graph option ‘backgroundColor’ to solve 1).
    I found one of your example which solve 2) Chart with different background colors using striplines.
    Now for 3) try this new one, This is really close but there’s a problem: The axisX stripLines are not shown.

    You can cheat and uncomment the opacity option of the axisY StripLine to have an idea of what’s expected, but I want my defined colors, without the opacity.

    It seems the Y Stripline is always displayed on top. How to proceed to get what I’d like please?
    Ideas: is there a way to add a “Z-index”-like or weight-priority to show one StripLine on top of another?

    Thanks!

    #29552

    @xavcactus,

    You can work around this using showOnTop property as shown in this JSFiddle.

    —-
    Manoj Mohan
    Team CanvasJS

    #29567

    Hi @manoj-mohan,

    Unfortunately you used opacity for the other ‘striplines’ and in combination with ‘showontop’ makes our data (the line here) behind the ‘stripline’. I would like to have the data on top.
    Can’t we simply have a background color please?! thanks

    #29598

    @xavcactus,

    Setting opacity and showOnTop properties are the nearest possible solution as of now.

    —-
    Manoj Mohan
    Team CanvasJS

    #29603

    Ok then please add a feature request if possible to add a plotBackgroundColor option to the graph please

    One image to get you the idea on the expected result : https://imgur.com/a/bvw1sM2

    #29613

    @xavcactus,

    Thanks for your feedback. We will look into this feature in our future releases.

    —-
    Manoj Mohan
    Team CanvasJS

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.