Home Forums Report Bugs bug: stackedColumn in chrome no longer working

bug: stackedColumn in chrome no longer working

Viewing 11 posts - 1 through 11 (of 11 total)
  • #10155

    Hello Everyone,

    I’ve made a script which auto generates a chart for me a few months ago. It all worked up until recently.
    It does no longer work in google chrome, but perfectly fine in Internet explorer and Microsoft Edge.


    Edge output: http://prntscr.com/atnrte
    Chrome Output: http://prntscr.com/atnrxy

    Does anyone have what (might) cause this to happen?

    Thanks in advance!



    Thanks for reporting this issue. But we are unable to reproduce it with chrome version 50. Here is the screenshot of your fiddle in chrome-v50. Can you please mention your chrome version along with OS.


    Hi Sanjoy,

    Thank you for your response. I had experienced this as well. However after refreshing the page a couple of times the graphs broke down once again.

    My specs are as following:

    Browser: Google Chrome Version 50.0.2661.75 m (Google Chrome is up to date.)
    OS: Microsoft Windows 10(.0.10586) Home 64bit NL.
    GPU: AMD Radeon HD 6450 (Sapphire/PCPartner)


    After a bit of thinking, I went through the settings of my browser and hit upon System >> Use hardware acceleration when available as this option was enabled.
    I turned this option off and restarted Chrome as suggested by the browser itself. All of the graphs which did not work before are now functioning normally.

    I believe that this is a temporary solution to my problems.

    [Temporary solution]
    * Open You Google Chrome settings.
    * Click on Show advanced settings.
    * Scroll to the bottom of the page.
    * Within the System section. Disable Use hardware acceleration when available.
    * Click on restart, this will reopen every opened tab.



    We are glad that you were able to fix the issue. We had seen similar Bug last year in one of the Chrome Updates which they fixed after sometime. Seems like the same/similar issue has reappeared in current version of Chrome. Hoping that they’ll resolve this issue soon. We’ll also try to reproduce this problem at our end in a normal canvas and report the same to Chromium team.


    Thansk for your support.

    I tried to reproduce this problem on my personal computer, instead of the computers at work.
    Unfortunately I was unable to reproduce this, making me think that this is an incompatibility of chrome with hardware acceleration video card.

    Once again;

    Work PC:
    Chrome: 50.0.2661.75 m
    Windows 10 Home
    AMD Radeon HD 6450 (Sapphire/PCPartner)

    Home PC:
    Chrome: 50.0.2661.75 m
    Windows 10 Pro
    MSI GTX 960 GAMING 4G (GeForce GTX 960)

    I hope this information will be of use.

    • This reply was modified 7 years, 7 months ago by Danny. Reason: Missing information
    • This reply was modified 7 years, 7 months ago by Danny. Reason: Readability


    Thanks for the information. Probably this is the reason why we have not been able to reproduce the issue at our end yet. We will look into it further.



    Can you please try using this latest build and let us know if it worked.



    Thanks for coming back to me.

    I have updated the version of CanvasJS from 1.7.0 to 1.8.1 beta3 and made sure my version of Chrome is up-to-date (version 51.0.2704.63 m).

    Testing this version without hardware acceleration, caused (as expected) no problems.
    Upon enabling hardware acceleration and restarting google chrome, I expected it not to work but it actually did.

    I have made sure to test this on multiple devices sharing the same bug.

    This issue is now solved, thanks!



    We have just released v1.8.1 GA. Kindly download the latest version and let us know your feedback. Refer to the release blog for more information.


    As of version v1.8.1 GA (actually 1.8.1 beta3) the bug which caused hardware acceleration in Google Chome to not display certain graphs correctly has been solved.

    I thank you kindly!

    PS: E-mails send by CanvasJS <noreply@canvasjs.com> are received in my spam folder.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.