Home forums Chart Support “Animation” doesn’t work.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #31471

    Hi, My name is doko.

    I wirte this text.
    “animationEnable:true,”
    “animationDuration:50000,”

    But “Animation” doesn’t work.
    Please help me the solution.

    I write sample project at “Jsbin” .
    https://jsbin.com/xotoholevo/edit?html,js,console,output

    Best regard.

    #31472
    #31481

    @bdoko,

    You can enable or disable animation in Chart by setting animationEnabled property. You seems to be setting it as animationEnable, changing it to animationEnabled should work fine in your case. If you are still facing issue, kindly create JSFiddle reproducing the issue you are facing and share it with us so that we can look into the code, understand the scenario better and help you resolve.

    I update the project in “Google drive”.
    https://drive.google.com/drive/folders/1xDFc-JTLbauMdI8-xQ_oIXkpfbiv_Xow?usp=sharing

    It seems like the sample project shared by you is restricted and requires permission. Can you please make the sample public so that we can access it?


    Vishwas R
    Team CanvasJS

    #31509

    Dear Mr. Vishwas R

    Thank you for replying.I’m glad to see your reply.

    I reconfigured “google drive”.So I think you can access it.

    https://drive.google.com/drive/folders/1xDFc-JTLbauMdI8-xQ_oIXkpfbiv_Xow?usp=sharing

    Would you please tell me the solution.

    Best regard.

    Doko

    #31521

    Doko,

    As mentioned in previous reply, you should use animationEnabled property to enable or disable animation. In the sample that you have shared, you seem to be mentioning it as animationEnable (d missing). Changing it to animationEnabled should work fine in your case.

    Note: As of now, animation happens only on the first render of the chart & not on every update.


    Vishwas R
    Team CanvasJS

    #31541

    Dear Mr. Vishwas R

    Thank you very much for replying.
    I’m glad to see the solution! I did not notice “d missing”.
    I fixed it so “Animation” worked!!:)

    Best regard.

    Doko

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.